SOLVED: Jetson nano : Snips installation

Hi Snips Devs!

I have Snips up and running on some Raspberrys. Now I like to run it on Jetson Nano.

I followed the TX1 installation guide.

Now I run into the following stacktrace:

root@power:/home/volker# sam init
Installing Snips Platform components. This may take a few minutes…
:heavy_check_mark: Updating aptitude repository
:heavy_check_mark: Installing dirmngr
:heavy_check_mark: Adding Snips APT source list
:heavy_check_mark: Adding Snips PGP public key
:heavy_check_mark: Updating aptitude repository
:heavy_check_mark: Installing Snips Platform, this could take a while, grab a cup of tea & relax
Adding current user to snips-skills-admin group for security
:heavy_multiplication_x: Failed to install platform: Error: sudo: no tty present and no askpass program specified
at SSH. (/usr/local/lib/node_modules/snips-sam/node_modules/node-ssh/lib/index.js:184:19)
at Generator.next ()
at step (/usr/local/lib/node_modules/snips-sam/node_modules/node-ssh/lib/index.js:39:191)
at /usr/local/lib/node_modules/snips-sam/node_modules/node-ssh/lib/index.js:39:361
at
at process._tickCallback (internal/process/next_tick.js:188:7)

I tried some suggestions to this error but with no gain

Any help appreciated

Volker

hello @volkerjaenisch,

sam init and sam setup audio will work properly with raspbian and the rpi3 only

for the jetson nano, please install the snips platform manually as described in https://docs.snips.ai/getting-started/quick-start-jetson-tx2

once the platform is installed, you can use sam to deploy your assistant.

Hello Marc!

If I install manually (following the jetson Tx2 guide) I run in the same problem:

root@power:/home/volker# sam install assistant
Fetching assistants done
? Choose the assistant you wish to install on the device haus2
Downloading assistant
Fetching assistants done
NLU training done
ASR training done
:heavy_multiplication_x: Unable to install the assistant: sudo: no tty present and no askpass program specified

Volker

Finally fixed the problem!

Just a sudoers problem.

  1. You should have the user you are working with given access without password. TAKE CARE!
  2. The sudoers rule for this particular user

volker ALL = (ALL:ALL) NOPASSWD: ALL

has to be AFTER the group rule

Allow members of group sudo to execute any command
%sudo   ALL=(ALL:ALL) ALL

since the user may be in this group so this settings will be overwritten if not AFTER these lines.

Cheers,
Volker

Hi Volker

How does the Jetson nano compare against the raspberry pies?

I am just starting out and I have only a Pi 2B lying around. I consider either getting a new 4B 4GB or a jetson nano as base unit. I might be able to borrow a nano from the office to play around, too.

Regards,
Toby