[Solved] Snips-asr and snips-injection fail to start, are linked against orce_load

Hello,

i tried installing Snips on a Raspberry Pi manually and via sam. Systemd tries starting snips-asr and snips-injection, but continuously fails to do so. Manually starting snips-asr or snips-injection fails with “Illegal instruction”.

I don’t know if it has anything to do with this, but when i run ldd against /usr/bin/snips-asr or snips-injection it gives

pi@raspberrypi:~ $ ldd /usr/bin/snips-asr
/usr/lib/arm-linux-gnueabihf/libarmmem.so (0xb6b2b000)
orce_load => not found
libsnips_kaldi.so => /usr/lib/libsnips_kaldi.so (0xb644b000)
[…]

So there might be a typo somewhere in the sources/build script (suppose it was a -force_load option somewhere).

OS: Raspbian 9.9
snips-asr version: 0.63.2
snips-injection version: 0.63.2

Any tips on how i can find the reason snips-asr and snips-injection fail to start?

Updated to snips-asr 0.63.3 and snips-injection 0.63.3, problem still exists.

Hi @ursaminorbeta,

That a strange one we never encounter.

Are you using a rasbian stretch or buster?

Can you provide the output of:

uname -a

and

dpkg -l | grep snips

Hi @SakanaSan,

I’m using Raspbian stretch

uname -a:

Linux raspberrypi 4.19.57+ #1244 Thu Jul 4 18:42:50 BST 2019 armv6l GNU/Linux

dpkg -l | grep snips:

ii libatlas3-base 3.10.3-1-snips armhf Automatically Tuned Linear Algebra Software, generic shared
ii snips-asr 0.63.3 armhf Snips Automatic Speech Recognition
ii snips-asr-model-en-500mb 0.6.0-alpha.4 armhf Generic model for Snips ASR (english only)
ii snips-audio-server 0.63.3 armhf Snips Audio Server command line interface
ii snips-dialogue 0.63.3 armhf Snips Dialogue Manager command line interface
ii snips-hotword 0.63.3 armhf Snips Hotword command line interface
ii snips-injection 0.63.3 armhf A CLI tool to manage words injection into Snips ASR models
ii snips-kaldi-atlas 0.24.2 armhf Snips/Kaldi C/C++ wrapper
ii snips-nlu 0.63.3 armhf Snips Natural Language Understanding command line interface
ii snips-platform-common 0.63.3 armhf Base package for configuration
ii snips-platform-voice 0.63.3 armhf Metapackage for snips-platform voice assistant
ii snips-skill-server 0.63.3 armhf Snips skill server command line interface
ii snips-template 0.63.3 armhf A CLI tool to work with templates for Snips actions
ii snips-tts 0.63.3 armhf Snips TTS
ii snips-watch 0.63.3 armhf CLI tool to monitor what the snips platform is doing

However, after some more googling, i think the problem might be “armv6l”, because this is a Raspberry Pi 1 and it’s architecture differs from Raspberry Pi’s 2&3. Maybe i’m better off using a Raspberry Pi 3 :thinking:.

Oh!

Ok, indeed, it cannot work on a pi1 :slight_smile:

The pi1 can still be used as a satellite if you want to find it a purpose :slight_smile:

Thank you for the clarification!
So, I’m sorry for the noise, nothing is broken, it just wasn’t designed to run on a Pi 1.

Will try using it as a satellite then.