The session was ended because one of the component didn't respond in a timely manner


#1

I think this was asked before but anyone has other solutions / ways to diagnosis?

I can’t get beyond wakeword. Sound test passes / all the snips services running, and created an intent with action . (along with a few existing actions) yet no luck.

$ sam watch

[21:58:24] Watching on localhost:1883 (MQTT)

[21:58:27] [Hotword] detected on site default, for model hey_snips

[21:58:27] [Asr] was asked to stop listening on site default

[21:58:27] [Hotword] was asked to toggle itself ‘off’ on site default

[21:58:27] [Dialogue] session with id ‘83c7ca85-6f74-45d3-b03c-ef0e5c81fe18’ was started on site default

[21:58:27] [AudioServer] was asked to play a wav of 41.1 kB with id ‘c1494432-71b8-4a80-a4e5-06f1ae9f782a’ on site default

[21:58:42] [Dialogue] session with id ‘83c7ca85-6f74-45d3-b03c-ef0e5c81fe18’ was ended on site default. The session was ended because one of the component didn’t respond in a timely manner

[21:58:42] [Asr] was asked to stop listening on site default

[21:58:42] [Hotword] was asked to toggle itself ‘on’ on site default


#2

you should use the search… this has been asked and answered 100’s of times


#3

First test your setup with some apps from the Snips Store. If that doesn’t work, tell us which apps you tried and show us the code of the app you created. Otherwise we don’t have enough information to help you.


#4

Thank you for your responses! @koan Here’s the list of apps I’m using. (@ozie is this yours? :slight_smile:

(I tried Google search with the msg but I couldn’t find any exact match besides the one I linked.)

$ sam install assistant -i proj_XrBXkQ16akNM
Downloading assistant

NLU training done
ASR training done
:heavy_check_mark: Deploying assistant to 192.168.0.31…
Checking for actions
Python skill lifidea.AppTest has 1 snippet:
lifidea
Python skill ozie.Calculations has 1 snippet:
ozie
Cloning skill CrystalMethod.Wikipedia from url: https://gitlab.smb-tec.com/snips.ai/skills/snips-wikipedia.git
Already up-to-date.

Generating actions based on the snippets, copying the actions in /var/lib/snips/skills

Setting up Python actions
:heavy_check_mark: Generating virtual environment for snips-wikipedia
:heavy_check_mark: Generating virtual environment for ozie.Calculations
:heavy_check_mark: Generating virtual environment for lifidea.AppTest

Checking actions for end-user parameters
i Action ozie.Calculations contains end-user parameters that need to be configured
? Please enter a value for the parameter [US_or_UK_metric] US
? Please enter a value for the parameter [exchange_rate_api] 5QRqAdT3RaEP3AYeFyKc7sDPajWdTq
? Please enter a value for the parameter [default_currency] AUD
i You can change these values later by editing the file located at /var/lib/snips/skills/ozie.Calculations/config.ini
Relaunching snips-skill-server
:heavy_check_mark: Snips assistant is now running. Say hey_snips to start!
i Run sam watch to see the logs


#5

What is the output of:

sam status

tail -f /var/log/syslog (while talking to Snips)


#6

$ tail -f /var/log/system.log

I don’t see any new msg (while talking to Snips)

$ sam status

Connected to device 192.168.0.31

OS version … Raspbian GNU/Linux 9 (stretch)
Installed assistant … pibot
Language … en
Hotword … hey_snips
ASR engine … snips
Status … Live

Service status:

snips-analytics … 0.60.8 (running)
snips-asr … 0.60.8 (running)
snips-audio-server … 0.60.8 (running)
snips-dialogue … 0.60.8 (running)
snips-hotword … 0.60.8 (running)
snips-nlu … 0.60.8 (running)
snips-skill-server … 0.60.8 (running)
snips-tts … 0.60.8 (running)

Here’s what I see


#7

It’s /var/log/syslog


#8

I have mac so no such file exists but here’s what I see from Rpi:

Dec 24 10:45:34 raspberrypi snips-hotword[2030]: INFO:snips_hotword_hermes : Hotword detected: site_id:default model:hey_snips (209ms ago)
Dec 24 10:45:34 raspberrypi snips-dialogue[1975]: INFO:snips_dialogue_lib::coordinator::coordinator: Site [default]: reset site -> turn off ASR and turn off Hotword
Dec 24 10:45:34 raspberrypi snips-dialogue[1975]: INFO:snips_dialogue_lib::coordinator::coordinator: Session [20687558-efb8-4e13-add5-5686963f182a]: The session has been created because the site “default” is free
Dec 24 10:45:34 raspberrypi snips-audio-server[2066]: INFO:snips_audio_portaudio : Playing “0abe9484-1fe6-4b2c-bacb-60f7524b56d4” using output “default”, wav spec: WavSpec { channels: 2, sample_rate: 22050, bits_per_sample: 16, sample_format: Int }
Dec 24 10:45:34 raspberrypi snips-audio-server[2066]: Expression ‘alsa_snd_pcm_hw_params_set_buffer_size_near( self->pcm, hwParams, &bufSz )’ failed in ‘src/hostapi/alsa/pa_linux_alsa.c’, line: 2079
Dec 24 10:45:34 raspberrypi snips-audio-server[2066]: Expression ‘PaAlsaStreamComponent_FinishConfigure( &self->playback, hwParamsPlayback, outParams, self->primeBuffers, realSr, outputLatency )’ failed in ‘src/hostapi/alsa/pa_linux_alsa.c’, line: 2733
Dec 24 10:45:34 raspberrypi snips-audio-server[2066]: Expression ‘PaAlsaStream_Configure( stream, inputParameters, outputParameters, sampleRate, framesPerBuffer, &inputLatency, &outputLatency, &hostBufferSizeMode )’ failed in ‘src/hostapi/alsa/pa_linux_alsa.c’, line: 2838
Dec 24 10:45:34 raspberrypi snips-audio-server[2066]: thread ‘ai.snips.audio.portaudio.player’ panicked at ‘called Result::unwrap() on an Err value: “SendError(…)”’, libcore/result.rs:1009:5
Dec 24 10:45:34 raspberrypi snips-audio-server[2066]: ERROR:snips_audio_server_hermes : could not play “0abe9484-1fe6-4b2c-bacb-60f7524b56d4”
Dec 24 10:45:34 raspberrypi snips-audio-server[2066]: -> caused by: UnanticipatedHostError
Dec 24 10:45:34 raspberrypi snips-hotword[2030]: INFO:snips_hotword_lib::audio : Audio thread for site default stopped.
Dec 24 10:45:49 raspberrypi snips-dialogue[1975]: INFO:snips_dialogue_lib::coordinator::coordinator: Session [20687558-efb8-4e13-add5-5686963f182a]: closing session which was active: Timeout
Dec 24 10:45:49 raspberrypi snips-dialogue[1975]: INFO:snips_dialogue_lib::coordinator::coordinator: Site [default]: reset site -> turn off ASR and turn on Hotword
Dec 24 10:45:49 raspberrypi snips-hotword[2030]: INFO:snips_hotword_lib::audio : Audio thread for site default started.


#9

I searched again with ‘alsa_snd_pcm_hw_params_set_buffer_size_near’ and there’s a suggestion about setting ‘sound_feedback_disabled_default = true’ not sure what this actually does (man page is not very helpful https://docs.snips.ai/guides/platform-articles/platform-configuration ) but after setting this it seem to work now! Thanks @koan


#10

that setting enables or disabled the “beep” sound snips can make when it hears the wake word


#11

@ozie Thanks! I’m using RaspiAudio with built in mic & speaker. Anything I need to do to avoid the error?