Unable to install under Buster

Hi.
I’m trying to install Snips under Raspbian Buster. Main keyserver from mit gives error “gpg: keyserver receive failed: No keyserver available” but changing to surfnet is successful.

Anyway, when i apt update I get the following error:

(…)
Ign:4 https://raspbian.snips.ai/buster stable InRelease
Err:5 https://raspbian.snips.ai/buster stable Release
404 Not Found [IP: 13.224.106.115 443]
Reading package lists… Done
E: The repository ‘blabla/buster stable Release’ does not have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

What can I do?

Hi !
Same here.
I’ve been trying to add https://raspbian.snips.ai/stretch to my apt sources just for testing, but there seem to be some dependencies missing in raspbian buster:
snips-tts requires libttspico-utils which is not installable (?)
snips-asr is not installable out of the box either, apparently

Regards

Same here. Also waiting for Buster support …
Unfortunately nobody from the Snips Dev team is replying and telling us when we can expect support for Buster to be available.

Subscribing ! Hope Snips dev people will give us a roadmap or so…

+1 I’ve just spent the whole day trying to get snips working before coming across this :frowning:

The Snips development team is tracking the issue:

Please do not clutter the issue discussion with comments not technically relevant to the issue

If anybody needs a Raspbian Stretch image for their project right now, the old images are a bit hard to track down on google but they’re available here: https://downloads.raspberrypi.org/raspbian/images/

2 Likes

Hello everyone,

The platform is clearly not ready for raspbian buster for multiple reasons and thus not officially supported.

One of those reason is that buster is still in testing phase on debian side.

You can follow the ticket @mustacheemperor provided, I could run the platform on a Pi4 running on raspbian Buster.

On our side we need to deploy a new package repository to support buster (additionally to stretch)
Meanwhile, just replace buster by strech in your apt source configuration

Some packages are missing on raspbian repositories (pico stuffes) and thus need some package cherry picking on debian repository.

[EDIT] For the ones using a Pi4, I could not have my seeed voice card (the PiHAT2) working correctly. On Pi3 + buster no issues at all.

1 Like

Yesterday Debian released Buster as latest stable.

Sorry, doesn’t work. After echo 'deb https://debian.snips.ai/buster stable main' > /etc/apt/sources.list.d/snips.list, apt update gives 404 error.

This was working… But snips-kaldi can’t install for now

Yes I saw that buster was released officially yesterday :slight_smile:

About the repo url, sorry I made a typo in the forum post, replace buster by stretch as stated in the ticket.

Hi,

Any updates on this? I tried replacing buster with stretch but some of the snips packages are not installed. This is what I got

OS version … Raspbian GNU/Linux 10 (buster)
Installed assistant … XXXXXX
Language … en
Hotword … hey_snips
ASR engine … snips
Status … Live

Service status:

snips-analytics … 0.63.2 (not running)
snips-asr … (not running)
snips-audio-server … 0.63.2 (running)
snips-dialogue … 0.63.2 (running)
snips-hotword … 0.63.2 (running)
snips-nlu … 0.63.2 (running)
snips-skill-server … 0.63.2 (not running)
snips-tts … (not running)

Hi @tpc-dev,

Check the ticket, all the information needed are provided on the github issue.

If you want to avoid issues, use a stretch image.

Hi @SakanaSan,

All good now. I use stretch image for now. Thanks!

1 Like