Wakeword Feedback interrupts ASR

asr

#1

If I speak out the wakeword “Hey Snips” and then do not wait for the Feedback sound “ding” to play completly the ASR misses quite a large portion from the speech.

With feedback turned of this delay between feedback and recognition is considerably shorter (not perfect though).

Is there a possibility to filter the feedback sound out so that I can say “Hey snips, turn on the light in one shot”?

Alternatively where can I find the sourcecode for the feedback sound? I would like to change it so that the feedback sound is only played when there is a slight silence after the wakeword is played but not when the “user” talks without a delay after the wakeword.


#2

No you can’t yet unfortunately. And the source code is not accessible


#3

I guess the only workaround then is to use an alternative hotword detector such as snowboy and send the “hermes” messages to stop listening when there is no speech and play a sound and start listening again.