Wakeword / Hotword "Hey Snips" doesn't work

#1

Hi,

I hope someone can help me. The default hotword is not recognized. I can’t find the error and I can’t find the problem in den forum.

I use a Raspberry Pi 3 B+ with Respeaker 6-Mic. I have everything installed as in the snips guide and in addition the drivers of the sound card.

The required services are running.
Command “sam status”:

Connected to device raspi-kitchen

OS version ................... Raspbian GNU/Linux 9 (stretch)
Installed assistant .......... Test
Language ..................... de
Hotword ...................... personal_hotword
ASR engine ................... snips
Status ....................... Live

Service status:

snips-analytics .............. 0.62.3 (not running)
snips-asr .................... 0.62.3 (running)
snips-audio-server ........... 0.62.3 (running)
snips-dialogue ............... 0.62.3 (running)
snips-hotword ................ 0.62.3 (running)
snips-nlu .................... 0.62.3 (running)
snips-skill-server ........... 0.62.3 (running)
snips-tts .................... 0.62.3 (running)

Command “aplay -l”:

**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
  Subdevices: 7/7
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: seeed8micvoicec [seeed-8mic-voicecard], device 0: bcm2835-i2s-ac10x-codec0 ac10x-codec0-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Command “arecord -l”:

**** List of CAPTURE Hardware Devices ****
card 1: seeed8micvoicec [seeed-8mic-voicecard], device 0: bcm2835-i2s-ac10x-codec0 ac10x-codec0-0 []
  Subdevices: 0/1
  Subdevice #0: subdevice #0

File “/etc/asound.conf”:

pcm.!default {
    type asym
    playback.pcm {
        type plug
        slave.pcm "hw:0,0"
    }
    capture.pcm {
        type plug
        slave.pcm "hw:1,0"
    }

I haven’t changed the file “/etc/snips.toml”. So the “snips-audio-server” section looks like this:

[snips-audio-server]
# frame = 256
# bind = "default@mqtt"
# mike = "Built-in Microphone"
# disable_playback = false
# disable_capture = false

Command “snips-hotword -v”:

snips-hotword 1.1.2 (0.62.3)

Command “snips-hotword”:

[12:08:21.088438] INFO :snips_hotword::server: Discovered audio_server default/mqtt, starting hotword listener
[12:08:21.088893] INFO :snips_hotword::server: Connecting using MQTT site-id default
[12:08:21.089902] INFO :snips_hotword_lib::audio: Audio thread for default started
[12:08:21.090399] INFO :snips_hotword_lib::audio: Net and VAD thread for site default started (vad inhibitor: true, vad messages: false

The commands “sam test speaker” and “sam test microphone” work fine!!

But I can say “Hey Snips” as often as I want. “sam watch” only provides:

[12:00:20] Watching on localhost:1883 (MQTT)

I hope someone has an idea what else I could try.

Thanks, Norman

#2

in your assistant you have the wake word not set the “hey snips” you have it set to use your own personal wakeword… and i am guessing you do not have set in the snips.toml your own personal wake word settings
Change it in the console assistant and reinstall assistant

#3

Oh - oh - thanks!!! What a mistake…