You are using pip version 18.1, however version 19.0.3 is available

#1

Hallo liebe Forumsler.
Ich beginne gerade mit snips und habe mir meinen Assistenten installiert. Leider kommt dort die Fehlermeldung “You are using pip version 18.1, however version 19.0.3 is available.” mit dem Hinweis “You should consider upgrading via the ‘pip install --upgrade pip’ command.”

Den Hinweis habe ich befolgt, am Problem hat es aber nichts geändert. Wenn ich das Wetter-Modul nutzen möchte, sollte ich eigentlich nach einem API-Schlüssel gefragt werden. Das passiert aber nicht. Deshalb vermute ich oben genanntes Problem als Ursache. Kann mir einer helfen?

#2

Hallo Ingolf,

ich habe exakt das selbe Problem und es nervt total. Der pip-upgrade klappt bei mir nicht und ich habe den Eindruck, daß das ganze System ziemlich zerschossen ist.
Ich wollte jetzt eigentlich hingehen, und auf einer jungfräulichen SD-Karte ALLES neu istallieren, aber jetzt habe ich gerade entdeckt, daß die Installation wohl um einiges komplexer geworden ist. Plötzlich soll ich noch Node, NPM und Git auf meinem Rechner installieren und frage mich, ob das alles wirklich notwendig ist…